Viết chương trình nhập vào ba số nguyên a, b, c. In ra ba số đó theo thứ tự giảm dần. Dữ liệu vào Ba số nguyên a,b,c. Kết quả In ra ba số đó theo thứ tự giảm dần Sample Input 6 3 Sample Output 6 3 2 Sample Input -243 -543 -123 Sample Output -123 -243 -543
2 câu trả lời
uses crt;
var a, b, c, max : integer;
begin
clrscr;
write('nhap ba so a, b, c : ');readln(a, b, c);
max := a;
if b > max then max := b;
if c > max then max := c;
if max = a then
if b > c then writeln(a, b:3, c:3) else writeln(a, c:3, b:3);
if max = b then
if a > c then writeln(b, a:3, c:3) else writeln(b, c:3, a:3);
if max = c then
if b > a then writeln(c, b:3, a:3) else writeln(c, a:3, b:3);
readln
end.
*Python:
a=[]
a.append(int(input())
a.append(int(input())
a.append(int(input())
a.sort()
print(a[2],a[1],a[0])
*C++:
#include <bits/stdc++.h>
using namespace std;
long long a,b,c;
long long mn,tb,mx;
int main()
{
cin >> a >> b >> c;
if (not (a==b and b==c)){
if (a>b){mx=a; mn=b;}
else {mx=b; mn=a;}
if (c>mx) mx=c;
if (c<mn) mn=c;
if (a<mx and a>mn) tb=a;
if (b<mx and b>mn) tb=b;
if (c<mx and c>mn) tb=c;
cout << mx << " " << tb << " " << mn;}
else cout << a << " " << b << " " << c;
}